ARCHIV 1999-2006

ARCHIV :: # 1667

Ghostprinting - wenn Druckaufträge verschwinden

Wir müssen mehr Druck machen!

Autor: bh - Datum: 23.01.2003

Manchmal kommt es unter MacOS X vor, daß Printjobs im Nirvana verschwinden. Diesem Rätsel (frißt UNIX etwa Daten?) ist Leser Marcel nun nachgegangen, und falls es dazu noch Fragen gibt: hier gibts einen Thread dazu im Forum. Hallo,
habe heute eine Problematik mit Mac OS X lösen können, die mir schon einige Zeit Kopfzerbrechen bereitet hatte: das Verschwinden von Print-Jobs im 'Nirgendwo'...

Hatte auch einige Zeit überlegt, auf welcher deutschen Mac-spezifischen Web-Seite ich dieses Troubleshooting am Besten posten könnte und bin zu dem Entschluss gekommen, dass ich Eure Seite am Besten finde, da ihr auch politisch auf meiner Wellenlänge seid... ;-)

Die folgende Fehlerbeschreibung und deren Problemlösung könnt ihr gern bei Euch veröffentlichen sowie an befreundete Web-Seiten-Betreiber weiterleiten.
Auch steht es Euch frei, Änderungen bezüglich meiner Formulierungen etc. vorzunehmen, denn ich erzähle definitiv zu zusammenhangslos und durcheinander - allerdings nur aus der Angst heraus, ein Detail zu vergessen.

Also dann:
von Zeit zu Zeit hatte ich das Problem, dass Print-Jobs zwar an den (Postscript)-Drucker geschickt wurden, dort aber nicht heraus kamen - eine Fehlermeldung gab es jedoch auch nicht!
Heute nun fand ich heraus, dass in meinem System zwei Printcenter vorhanden waren - und diese wiederum in Applications/Dienstprogramme bzw. Applications/Utilities.

Sicher kennt auch Ihr die Problematik, dass der Ordner Applications mal 'Applications' heißt uns mal 'Programme'.

Das ist zwar nicht schön und durchaus ärgerlich - aber (bisher zumindest) nicht weiter tragisch (wird ja immer nur intern 'umbenannt').

Anders verhält es sich jedoch mit 'Dienstprogramme' bzw. 'Utilities'.

Diese wurden nämlich nicht einfach je nach Situation 'umbenannt' sondern waren bei mir real vorhanden - höchstwahrscheinlich erkannte ein Updater des Systems (von 10.2 auf 10.2.1 auf 10.2.2 auf 10.2.3) den Ordner nicht korrekt und kopierte dann die neuen Programm-Versionen statt in den 'Dienstprogramme'-Ordner in einen neuen Ordner den er dann 'Utilities' nannte.

In meinem Ordner 'Utilities' waren die jeweils aktuelleren Programm-Versionen vorhanden, im Ordner 'Dienstprogramme' die älteren Versionen (wobei manche Versionen offensichtlich gleich waren - zu erkennen anhand der gleichen Versions-Nummer, Build-Nummer und Programm-Größe; dazu aber später noch mehr im Detail).

Das 'Print Center" lag im 'Dienstprogramme'-Ordner in Version 2.0 vor, im 'Utilities'-Ordner in Version 2.2.

Und genau das führte scheinbar zu Konflikten - denn manchmal druckte er und manchmal nicht.

Herausgefunden habe ich das mehr oder weniger durch einen glücklichen Zufall: da ich in einer frühen Beta-Version von Jaguar das Problem hatte, dass sich das 'Print Center' nicht automatisch startete, wenn man einen Druck-Job abschickte, gewöhnte ich mir an, das Programm in das Dock zu ziehen und es dort manuell zu starten.

Heute sah ich zu meinem Erstaunen, dass nicht das eingedockte 'Print Center' startete sondern offensichtlich eine andere Version - es waren also zwei 'Print Center' im Dock zu sehen.

Habe nun alle alten Versionen gelöscht und auch den Ordner 'Dienstprogramme', so dass nur noch die aktuellen Versionen im Ordner 'Utilities' vorhanden sind.

Und alles funzt wieder und er druckt alles ohne Probleme! :-)


Aber noch eine Anmerkung zu den verschiedenen Programm-Versionen: der 'NetInfo Manager' z.B. war in beiden Ordnern in Version 1.3 vorhanden, die Build-Nummer war bei beiden V98.
Allerdings war die Version im 'Dienstprogramme'-Ordner offensichtlich trotzdem eine andere (ältere?), da sie nur 616KB groß war, die Version im 'Utilities'-Ordner aber 732KB.

Ähnliche Schwierigkeiten bei der Unterscheidung der Versionen gab es ja erst vor kurzem auch bei 'Safari' - hier muss Apple unbedingt eine klarere Linie einhalten und noch nachbessern.

Was ich aber am meisten befürchte ist, dass zwar noch eine Version 10.2.4 und vielleicht ja noch eine Version 10.2.5 kommen wird - dann aber wieder ein kostenpflichtiges Update auf Version 10.3 (für laut Gerüchte-Seiten 299,- $!!!).
Ich finde weniger die Problematik des Update-Preises erwähnenswert als vielmehr die Tatsache, dass man dadurch nie eine 100%ig fehlerfreie Version von 10.2 Jaguar erhalten wird.

Ehrlich gesagt erinnert mich diese Praktik ein wenig an diese Firma namens 'Kleinweich' - hoffen wir also, dass es diesmal auch faire Update/Upgrade-Preise geben wird!!!

Kommentare

Was sollen die blöden Gerüchte?

Von: Marcus | Datum: 23.01.2003 | #1
Hi,

finde ja gut, was Du so herausgefunden hast, aber die Mutmassung über 10.3 ist völlig unangebracht. Nur weil irgendwelche Gerüchtseiten irgendwas posten, tust Du so als sei es beschlossene Sache. Mal ganz cool abwarten und dann sehen wir mal weiter. Kein Wunder, dass Apple das Treiben der Gerüchteseiten unterbinden will, denn es trägt wirklich nicht zum Guten bei. Eher zum Gegenteil. Und das ist ganz egal, ob Apple positiv oder negativ überrascht...

Gruß, Marcus

Jaguar Beta?

Von: sandro | Datum: 23.01.2003 | #2
>> ...da ich in einer frühen Beta-Version von Jaguar das Problem hatte...

Könnte es sein das dein Problem mit den zwei "Dienstprogramme"-Ordnern daher rührte? Habe nämlich von diesem Problem bisher nirgendwo anders was gelesen.

Konfigurationsfehler?

Von: M. Bresink | Datum: 23.01.2003 | #3
Das hört sich eher so an, als würdest Du ein fehlerhaftes Programm einsetzen (möglicherweise ein AppleScript, das den Finder benutzt, um irgendwelche Dinge zu tun). Der Ordner "/Applications" heißt IMMER so, und der Apple-Installer verwendet aus gutem Grund IMMER feste Pfadnamen (weltweit die gleichen), um Updates zu installieren. Es ist technisch unmöglich, dass der Updater von sich aus etwas unter einem "deutschen Pfadnamen" installiert.

Der Ordner wird auch niemals umbenannt, sondern es gibt eine Übersetzungsfunktion im Finder, die den Ordner "/Applications/Utilities" je nach gerade eingestellter Sprache anzeigt. Der Finder zeigt nicht ein echtes Abbild der Platte, sondern ein stark gefilterte und übersetzte Fassung davon.

fehler und verwirrung, sonst nichts.

Von: Don Del Aqua | Datum: 23.01.2003 | #4
marcel bresink hat recht.
die apple-standard ordner sind immer gleich.
wenn ein lokalisiertes programm z.b. im dia-
log öffnen oder sichern die ordner listet, dann
in der aktuell eingestellten sprache. wenn das
programm nicht lokalisiert ist, dann immer mit
dem standard-namen, hier also applications/
utilities . . . ( das ist noch ganz logisch )

jetzt kommts etwas verwirrendes =>

wenn man in den darstellungsoptionen des
finder die checkbox "suffixe immer aus-
blenden" deaktiviert, dann sind nämlich
nicht nur alle file-extension zu sehen,
also "dondelaqua.pdf" etc. SONDERN,
mit einmal werden die haupt-ordner
NICHT mehr lokalisiert ausgegeben,
also "Benutzer" genannt, sondern
heißen wieder "User" und so weiter.

sorry freunde, aber das ist nicht nur
unlogisch, sondern hat nach meinem
verständnis auch zusammenhangsmä-
ßig nichts miteinander zu tun . . . ich
nenne das deshalb einen BUG, schlicht
und einfach . . . und werde apple dazu
auch ein feedback schreiben. ( ich ver-
mute nämlich, daß das kein mensch um-
stellt und daß das deshalb auch nie je-
mandem auffällt . . . oder was sagt ihr ?)

adios, don del aqua

und nochmal ganz deutlich !!! =>>>
@marcel bresink => danke für solche
wunderbaren tools wie dein geniales
THINKER TOOL . . . für die ständige
weiterentwicklung und die hohe qua-
lität dieser FREEWARE . . . DANKE :-)

für die, die's noch nicht wußten, aber
jetzt wissen wollen . . . hier gehts lang:

http://www.bresink.de/osx/index-de.html

suffix-/lokalisierungs-fehler

Von: kross | Datum: 23.01.2003 | #5
ich habe fast 3 tage gebraucht um den zusammenhang zwischen den sichtbaren suffixen und den "nicht-mehr-lokalisierten"-ordnern herauszufinden. - war ehrlich sauer.

kross

Marcel:

Von: Kai | Datum: 23.01.2003 | #6
"@marcel bresink => danke für solche
wunderbaren tools wie dein geniales
THINKER TOOL . . ."

Ja, und Tinkertool erstmal, das ist sogar der Hit in Dosen! ..oder eben gerade nicht, hehe! ;-)

nachtrag . . . wo wir gerade bei bugs sind . . .

Von: Don Del Aqua | Datum: 23.01.2003 | #7
http://www.macguardians.de/index.php?p=1665&c=1#3427

Re: Marcel

Von: MaX | Datum: 23.01.2003 | #8
@Marcel

Danke Danke Danke - für das Jaguarbuch (wenn ich dafür hier noch mal eben Schleichwerbung machen darf - http://www.bresink.de/jaguarbuch.html )
Das ist das beste Buch was mir je für OS X unter die Finger gekommen ist. Selten ein Computerbuch so verschlungen.
Kann ich nur allen empfehlen...
Wann kommt der nächste Teil??

MaX

nur kurz angemerkt

Von: derschmiegel | Datum: 24.01.2003 | #9
"wenn man in den darstellungsoptionen des finder die checkbox "suffixe immer aus- blenden" deaktiviert, dann.."

- es sind nicht die "Darstellungsoptionen" des Finders, sondern die "Einstellungen"

- die Checkbox muss aktiviert sein und nicht deaktiviert

...nicht aus Klugscheisserei, sondern zum Nachvollziehen

@derschmiegel => du hast recht :-)

Von: Don Del Aqua | Datum: 24.01.2003 | #10
das passiert, wenn man vor der grauen dose
im office sitzt und trotzdem mitreden will :-)

ich hatte es aus'm kopf gekramt und damit
lag ich falsch . . . der bug ist zwar so, die
einstellungen aber, wie du gesagt hast :-)

adios, don del aqua